API Issues due to Easypost Errors

Incident Report for VESYL

Monitoring

Easypost is reporting that they are back up and stable. We will continue to monitor before formally resolving this ticket.
Posted May 11, 2026 - 10:14 PDT

Investigating

Easypost, an upstream partner and label provider for VESYL, has an elevated error rate. We are investigating.
Posted May 11, 2026 - 09:33 PDT
This incident affects: VESYL Label API.